Render error detected i915

render error detected i915

Modifiers specified, but DRI is too old 00:00:00.572 [ERROR] [render/egl.c:596] dmabuf import extension not present 00:00:00.572 [ERROR]. Hi, with today's -next I got this: [drm] capturing error event; look for more information in /sys/kernel/debug/dri/0/i915_error_state i915: render error. [drm] GPU crash dump saved to /sys/class/drm/card0/error [drm] GPU hangs can indicate a bug anywhere in the i915: render error detected, EIR: 0x00000010. render error detected i915

Agree, very: Render error detected i915

Sdram ecc error cisco 2811
CDWBIOS READ ERROR
RUNTIME ERROR 429 WINDOWS 7

Arch Linux

Kernel 3.0.3-1
Intel 915GM/GM/910GML Express graphics controller
32-bit system
Sony Vaio, 1.5GB RAM, Intel Pentium M 1.73GHz

My system boots to normal text console.  This particular machine had not been updated for a while (about 2 months I'd guess). After getting it up to date, I get some kernel errors to the console.  This happens after I've been logged in for about 30 seconds, before starting X.

Errors read:-

[  361.910654] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[  361.911684] render error detected, render error detected i915, EIR: 0x00000010
[  361.913304] page table error
[  361.913304]   PGTBL_ER: 0x00000100
[  361.913304] [drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
[  361.913304] render error detected, EIR: 0x00000010
[  361.913304] page table error
[  361.913304]   PGTBL_ER: 0x00000100

After this, I can start X and everything appears to be normal.  This machine has always been unusual (especially for an Intel laptop) in that Linux loves it and has always run really smoothly on it, although it's now old and comparatively weak.

Any idea if I should ignore this error, or if not, what can I do about it?

Thanks!

Last edited by VSpike (2011-08-30 09:14:53)

tail -1

Add the kernel parameter to your boot loader configuration.

Vulkan error on applications start

Tango-inaccurate.pngThe factual accuracy of this article or section is disputed.Tango-inaccurate.png

Reason: Need confirmation 676 error phone line is busy other users (Discuss in Talk:NVIDIA/Troubleshooting)

On executing an application that require Vulkan acceleration, if you get this error

Vulkan call failed: -4

try to delete the or directory.

Extreme lag on Xorg

Tango-inaccurate.pngerror 22 mounting ext3 height="48">The factual accuracy of this article or section is disputed.Tango-inaccurate.png

Reason: According to an NVIDIA developer this issue is not specific to GNOME and the rest of the comments on the issue do not mention multi-monitor setups. (Discuss in Talk:NVIDIA/Troubleshooting)

A common issue with Mutter is that animations, video playback and gaming cause extreme desktop lag on Xorg.

See NVIDIA/Tips and tricks#Preserve video memory after suspend.

This should resolve this issue, however if it did not, you are most likely out of luck. One way you can remedy this issue is by adding these options:

/etc/environmentCLUTTER_DEFAULT_FPS=YOUR_MAIN_DISPLAY_REFRESHRATE __GL_SYNC_DISPLAY_DEVICE=YOUR_MAIN_DISPLAY_OUTPUT_NAME

turning and off within NVIDIA Settings, and configuring NVIDIA Settings to launch on startup using the flag render error detected i915. This will still result in a laggy desktop behavior, in particular on an eventual second (or third) monitor, but it should be much better.